'Database/spark'에 해당하는 글 1건



spark 내 maven 으로 하둡관련 설치 시  아래와 같이 에러가 난다면 


 [WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

Detected Maven Version: 3.0.5 is not in the allowed range 3.3.3.

[INFO] ------------------------------------------------------------------------

[INFO] Reactor Summary:

[INFO] 

[INFO] Spark Project Parent POM .......................... FAILURE [2:25.599s]

[INFO] Spark Project Launcher ............................ SKIPPED

[INFO] Spark Project Networking .......................... SKIPPED

[INFO] Spark Project Shuffle Streaming Service ........... SKIPPED

[INFO] Spark Project Unsafe .............................. SKIPPED

[INFO] Spark Project Core ................................ SKIPPED

[INFO] Spark Project Bagel ............................... SKIPPED

[INFO] Spark Project GraphX .............................. SKIPPED

[INFO] Spark Project Streaming ........................... SKIPPED

[INFO] Spark Project Catalyst ............................ SKIPPED

[INFO] Spark Project SQL ................................. SKIPPED

[INFO] Spark Project ML Library .......................... SKIPPED

[INFO] Spark Project Tools ............................... SKIPPED

[INFO] Spark Project Hive ................................ SKIPPED

[INFO] Spark Project REPL ................................ SKIPPED

[INFO] Spark Project YARN ................................ SKIPPED

[INFO] Spark Project Assembly ............................ SKIPPED

[INFO] Spark Project External Twitter .................... SKIPPED

[INFO] Spark Project External Flume Sink ................. SKIPPED

[INFO] Spark Project External Flume ...................... SKIPPED

[INFO] Spark Project External Flume Assembly ............. SKIPPED

[INFO] Spark Project External MQTT ....................... SKIPPED

[INFO] Spark Project External MQTT Assembly .............. SKIPPED

[INFO] Spark Project External ZeroMQ ..................... SKIPPED

[INFO] Spark Project External Kafka ...................... SKIPPED

[INFO] Spark Project Examples ............................ SKIPPED

[INFO] Spark Project External Kafka Assembly ............. SKIPPED

[INFO] Spark Project YARN Shuffle Service ................ SKIPPED

[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 2:29.749s

[INFO] Finished at: Tue May 17 12:55:42 KST 2016

[INFO] Final Memory: 21M/52M

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.4:enforce (enforce-versions) on project spark-parent_2.10: Some Enforcer rules have failed. Look above for specific messages explaining why the rule failed. -> [Help 1]



spark 으로 다운받은 maven 이 버전이 낮아서 생기는 에러라고 합니다. 


헌데 spark 최신버전에서도 이게 고쳐지지가 않다는....(어쩌라는거지??)


허면 직접 maven 을 설치해서 실행하면 됩니다. (maven 3.3.3 이상 버전으로 설치 해야 합니다.)



sudo apt-get purge -y maven


$ wget http://apache.cs.utah.edu/maven/maven-3/3.3.3/binaries/apache-maven-3.3.3-bin.tar.gz


$ tar -zxf apache-maven-3.3.3-bin.tar.gz


$ sudo cp -R apache-maven-3.3.3 /usr/local


$ sudo ln -s /usr/local/apache-maven-3.3.3/bin/mvn /usr/bin/mvn


$ echo "export M2_HOME=/usr/local/apache-maven-3.3.3" >> ~/.profile


$ source ~/.profile


$ echo "Maven is on version `mvn -v`"



Maven is on version Apache Maven 3.3.3 (7994120775791599e205a5524ec3e0dfe41d4a06; 2015-04-22T20:57:37+09:00)

Maven home: /usr/local/apache-maven-3.3.3

Java version: 1.7.0_101, vendor: Oracle Corporation

Java home: /usr/lib/jvm/java-7-openjdk-amd64/jre

Default locale: en_US, platform encoding: UTF-8

OS name: "linux", version: "3.19.0-25-generic", arch: "amd64", family: "unix"



버전 확인 완료.


다시 스팍 설치 


$ mvn -Pyarn -Phadoop-2.4 -Dhadoop.version=2.4.0 -DskipTests clean package 


설치 됨!!!!


저작자 표시
신고

'Database > spark' 카테고리의 다른 글

spark maven error  (0) 2016.05.19

WRITTEN BY
No.190
세계정복의 시작점

받은 트랙백이 없고 , 댓글이 없습니다.
secret